Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OSError[126]?
#1
I recently downloaded the binaries from itch.io and even got sdl2/pysdl2 to work (I think that's needed).  I want to code using tilengine with python on a Windows 10 (x64) computer.

But here's my Problem: when I'm trying to import the module, there's an error that says that there's no module named 'tilengine'.
I even know why: I didn't install tilengine or at least, python doesn't know that the module even exists on my computer.

Then I tried to import it while in the tilengine\samples\python folder and also in the tilengine\bindings\python folder, because those are the two folders where tilengine.py is located.

There, I got another error:

Code:
C:\Development\Tilengine_windows_x64\bindings\python>python
Python 3.7.0 (v3.7.0:1bf9cc5093, Jun 27 2018, 04:59:51) [MSC v.1914 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import tilengine
Traceback (most recent call last):
 File "<stdin>", line 1, in <module>
 File "C:\Development\Tilengine_windows_x64\bindings\python\tilengine.py", line 271, in <module>
   _tln = cdll.LoadLibrary("Tilengine.dll")
 File "C:\Development\Python\Python37\lib\ctypes\__init__.py", line 434, in LoadLibrary
   return self._dlltype(name)
 File "C:\Development\Python\Python37\lib\ctypes\__init__.py", line 356, in __init__
   self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] The specified module could not be found

This is the point where I dont know what to do next and I got no Idea what the problem even is.
Does anybody know how to move on?

Greetings, Sam.

P.S: Could you also tell me how to install tilengine so I don't have to put my code in the samples folder? At this point I only have the folder structure from itch.io copied into my development folder in C:\ and I don't think that's right.

Edit: I'm rather new to coding, so sorry if my question is kinda stupid, should've mentioned that.


Messages In This Thread
OSError[126]? - by insane01 - 07-26-2018, 09:54 PM
RE: OSError[126]? - by megamarc - 07-27-2018, 02:23 AM
RE: OSError[126]? - by insane01 - 09-16-2018, 06:31 PM

Forum Jump:


Users browsing this thread: 2 Guest(s)